문제 난이도 | 유형 |
🥇골드 4티어 | 데이크스트라, 최단 경로, 우선순위 큐 |
문제
시간 제한 | 메모리 제한 | 제출 | 정답 | 맞힌 사람 | 정답 비율 |
1 초 | 128 MB | 7417 | 3813 | 3063 | 50.271% |
예은이는 요즘 가장 인기가 있는 게임 서강그라운드를 즐기고 있다. 서강그라운드는 여러 지역중 하나의 지역에 낙하산을 타고 낙하하여, 그 지역에 떨어져 있는 아이템들을 이용해 서바이벌을 하는 게임이다. 서강그라운드에서 1등을 하면 보상으로 치킨을 주는데, 예은이는 단 한번도 치킨을 먹을 수가 없었다. 자신이 치킨을 못 먹는 이유는 실력 때문이 아니라 아이템 운이 없어서라고 생각한 예은이는 낙하산에서 떨어질 때 각 지역에 아이템 들이 몇 개 있는지 알려주는 프로그램을 개발을 하였지만 어디로 낙하해야 자신의 수색 범위 내에서 가장 많은 아이템을 얻을 수 있는지 알 수 없었다.
각 지역은 일정한 길이 l (1 ≤ l ≤ 15)의 길로 다른 지역과 연결되어 있고 이 길은 양방향 통행이 가능하다. 예은이는 낙하한 지역을 중심으로 거리가 수색 범위 m (1 ≤ m ≤ 15) 이내의 모든 지역의 아이템을 습득 가능하다고 할 때, 예은이가 얻을 수 있는 아이템의 최대 개수를 알려주자.
주어진 필드가 위의 그림과 같고, 예은이의 수색범위가 4라고 하자. ( 원 밖의 숫자는 지역 번호, 안의 숫자는 아이템 수, 선 위의 숫자는 거리를 의미한다) 예은이가 2번 지역에 떨어지게 되면 1번,2번(자기 지역), 3번, 5번 지역에 도달할 수 있다. (4번 지역의 경우 가는 거리가 3 + 5 = 8 > 4(수색범위) 이므로 4번 지역의 아이템을 얻을 수 없다.) 이렇게 되면 예은이는 23개의 아이템을 얻을 수 있고, 이는 위의 필드에서 예은이가 얻을 수 있는 아이템의 최대 개수이다.
입력
첫째 줄에는 지역의 개수 n (1 ≤ n ≤ 100)과 예은이의 수색범위 m (1 ≤ m ≤ 15), 길의 개수 r (1 ≤ r ≤ 100)이 주어진다.
둘째 줄에는 n개의 숫자가 차례대로 각 구역에 있는 아이템의 수 t (1 ≤ t ≤ 30)를 알려준다.
세 번째 줄부터 r+2번째 줄 까지 길 양 끝에 존재하는 지역의 번호 a, b, 그리고 길의 길이 l (1 ≤ l ≤ 15)가 주어진다.
출력
예은이가 얻을 수 있는 최대 아이템 개수를 출력한다.
예제 입력
5 5 4
5 7 8 2 3
1 4 5
5 2 4
3 2 3
1 2 3
예제 출력
23
풀이
최근에는 그래프 그림에 간선에 비용만 그려져 있어도 최단 경로 알고리즘일 수 있다고 의심부터 한다. 실제로 이 문제는 데이크스트라 알고리즘으로 해결할 수 있다. 시작 지점을 1부터 n까지 순회하면서 데이크스트라 알고리즘의 결과를 받아온다. 그리고 그 결과에서 m의 값을 초과하지 않는 경우 해당 지역의 아이템 수를 더하고 마지막에 최댓값을 출력했다.
코드
const readline = require("readline");
const rl = readline.createInterface({
input: process.stdin,
output: process.stdout,
});
const input = [];
rl.on("line", function (line) {
input.push(line);
}).on("close", function () {
const [n, m] = input.shift().split(" ").map(Number);
const item = input.shift().split(" ").map(Number);
solution(
input.map((v) => v.split(" ").map(Number)),
item,
n,
m
);
process.exit();
});
class MinHeap {
constructor() {
this.heap = [null];
}
push(value) {
this.heap.push(value);
let currentIndex = this.heap.length - 1;
let parentIndex = Math.floor(currentIndex / 2);
while (parentIndex !== 0 && this.heap[parentIndex].cost > value.cost) {
this._swap(parentIndex, currentIndex);
currentIndex = parentIndex;
parentIndex = Math.floor(currentIndex / 2);
}
}
pop() {
if (this.isEmpty()) return;
if (this.heap.length === 2) return this.heap.pop();
const returnValue = this.heap[1];
this.heap[1] = this.heap.pop();
let currentIndex = 1;
let leftIndex = 2;
let rightIndex = 3;
while (
(this.heap[leftIndex] &&
this.heap[currentIndex].cost > this.heap[leftIndex].cost) ||
(this.heap[rightIndex] &&
this.heap[currentIndex].cost > this.heap[rightIndex].cost)
) {
if (this.heap[leftIndex] === undefined) {
this._swap(rightIndex, currentIndex);
} else if (this.heap[rightIndex] === undefined) {
this._swap(leftIndex, currentIndex);
} else if (this.heap[leftIndex].cost > this.heap[rightIndex].cost) {
this._swap(rightIndex, currentIndex);
} else if (this.heap[leftIndex].cost <= this.heap[rightIndex].cost) {
this._swap(leftIndex, currentIndex);
}
leftIndex = currentIndex * 2;
rightIndex = currentIndex * 2 + 1;
}
return returnValue;
}
isEmpty() {
return this.heap.length === 1;
}
_swap(a, b) {
[this.heap[a], this.heap[b]] = [this.heap[b], this.heap[a]];
}
}
function dijkstra(road, N, start) {
const heap = new MinHeap();
heap.push({ node: start, cost: 0 });
const dist = [...Array(N + 1)].map(() => Infinity);
dist[start] = 0;
while (!heap.isEmpty()) {
const { node: current, cost: currentCost } = heap.pop();
for (const [src, dest, cost] of road) {
const nextCost = cost + currentCost;
if (src === current && nextCost < dist[dest]) {
dist[dest] = nextCost;
heap.push({ node: dest, cost: nextCost });
} else if (dest == current && nextCost < dist[src]) {
dist[src] = nextCost;
heap.push({ node: src, cost: nextCost });
}
}
}
return dist;
}
function solution(road, item, n, m) {
const result = [];
for (let i = 1; i <= n; i++) {
const dist = dijkstra(road, n, i);
let temp = 0;
for (let j = 0; j < item.length; j++) {
if (dist[j + 1] <= m) temp += item[j];
}
result.push(temp);
}
console.log(Math.max(...result));
}
'CS > 알고리즘' 카테고리의 다른 글
[백준 #1644] 소수의 연속합, 자바스크립트 풀이 (0) | 2022.10.11 |
---|---|
[백준 #1806] 부분합, 자바스크립트 풀이 (0) | 2022.10.11 |
[백준 #1916] 최소비용 구하기, 자바스크립트 풀이 (0) | 2022.10.08 |
[백준 #7576] 토마토, 자바스크립트 풀이 (1) | 2022.10.08 |
[백준 #17144] 미세먼지 안녕!, 자바스크립트 풀이 (0) | 2022.10.07 |